[TENSORFLOW[cpu]-CHATBOT] How to limit the usage of rams and cpu.

by: Blacklight, 3 months ago


My PC specs:
$ inxi -Fxz

System:    Host: ULTIMATEWARE Kernel: 4.14.0-13-generic x86_64
           bits: 64 gcc: 7.2.0
           Desktop: Gnome  (Gtk 3.22.26-2ubuntu1)
           Distro: Ubuntu Bionic Beaver (development branch)
Machine:   Device: desktop Mobo: INTEL model: N/A serial: N/A
           BIOS: American Megatrends v: 080015 date: 07/07/2015
CPU:       Dual core Intel Core i5 650 (-HT-MCP-)
           arch: Nehalem rev.2 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12765
           clock speeds: max: 3191 MHz 1: 3191 MHz 2: 3191 MHz 3: 3191 MHz
           4: 3191 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: intel
           Resolution: 1280x1024@75.02hz
           OpenGL: renderer: Mesa DRI Intel Ironlake Mobile
           version: 2.1 Mesa 17.2.4 Direct Render: Yes
Audio:     Card Intel 5 Series/3400 Series High Def. Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.14.0-13-generic
Network:   Card: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 02:00.0
           IF: ens133 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 850.9GB (16.9% used)
           ID-1: /dev/sda model: WDC_WD3200JS size: 320.1GB
           ID-2: /dev/sdb model: Hitachi_HTS54755 size: 500.1GB
           ID-3: USB /dev/sdc model: Ultra size: 30.8GB
Partition: ID-1: / size: 46G used: 17G (39%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 142G used: 86G (64%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 5.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 221 Uptime: 13 min Memory: 1846.2/3748.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.45

How do I edit the settings such that my computer won't freeze during the training process?



You must be logged in to post. Please login or register an account.